Paylocity Provisioning Error: "User provisioning failed with msg=[Matching user not found]"
Identity Governance
Okta Classic Engine
Okta Identity Engine
Overview

Okta users who have the application Paylocity assigned have a provisioning error similar to: 

User provisioning failed with msg=[Matching user not found].

 

Applies To
  • Okta Integration Network (OIN)
  • User Provisioning
  • Paylocity
Cause

This error may be thrown as a result of Create Users not being enabled in Provisioning settings in Applications > Paylocity > Provisioning To App.

Solution
  1. Go to Okta Admin Console and navigate to Applications > Paylocity > Provisioning > To App.
  2. Click Edit. Select the Provisioning Feature Create Users, if Okta should be creating user accounts in Paylocity. Click Save.
  3. Afterward, attempt the user provisioning again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.

 tasks 

  1. After identifying the failed task for the user that should be retried, click on Retry Selected.

Related Resources

Recommended content

No recommended content found...