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Expensify Provisioning Error: "Automatic provisioning of user to app Expensify failed: Matching user not found"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Expensify OIN App provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <username> to app Expensify failed: Matching user not found


Error 

 
Applies To
  • Expensify OIN App
  • Provisioning
Cause

This error is thrown because the Expensify OIN application does not support the Create Users Provisioning Feature (e.g., Provision Users from Okta to the Expensify app is not supported).
Create Users feature is not available in Provisioning settings in Applications > Expensify > Provisioning > To App.
 

Solution

As Expensify OIN app does not support the "Create Users" Provisioning Feature, the user account needs to exist on the Expensify side first, then the user can be assigned to the Expensify app in Okta so that it will match the existing user in Expensify. User match will be based on Username in Okta.
Verify that the user is already present in Expensify app, please check the below details:

 
  1. Go to Applications > Expensify > Assignment tab.
  2. Click the pencil of the user > check the username. Verify if this username is the exact username that is on the Expensify side.
  3. Check if the user is active on the Expensify side.

If the issue persists, please contact Expensify support for more details and steps on how to resolve this error.

Related References

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Expensify Provisioning Error: "Automatic provisioning of user to app Expensify failed: Matching user not found"