<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Atlassian Jira Server Provisioning Flow Fails with Error "Automatic provisioning of user to app Atlassian Jira Server failed: Matching user not found"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Atlassian Jira Server provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <username> to app Atlassian Jira Server failed: Matching user not found.
 

Applies To
  • Atlassian Jira Server
  • Provisioning
  • Error
Cause

This error is thrown because the Create Users feature is not enabled in the Provisioning settings under Applications > Atlassian Jira Server > Provisioning > To App.

Solution
  1. Go to Okta Admin Console and navigate to Applications > Applications > Atlassian Jira Server > Provisioning > To App.

  2. Click Edit. Select the Provisioning Feature Create Users if it is desired to enable it > click the Save button.

  3. Afterwards, attempt the user provisioning again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks
    Tasks 

  4. After identifying the failed task for the user that should be retried, click on Retry Selected.

 

Related References

Loading
Atlassian Jira Server Provisioning Flow Fails with Error "Automatic provisioning of user to app Atlassian Jira Server failed: Matching user not found"