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Coupa Provisioning Error "The credentials used to connect to the API were invalid; please check your configuration"

Okta Integration Network
Okta Classic Engine
Okta Identity Engine

Overview

Coupa provisioning flow fails with the following error visible in the Okta dashboard:
 

Automatic provisioning of user <user> to app Coupa failed: L10N_ERROR[app.auth_error.null]


Okta System logs show the following error:

 

FAILURE: The credentials used to connect to the API were invalid; please check your configuration


 

Applies To

  • Coupa
  • Provisioning
  • Error

Cause

The Coupa credentials used for creating the API connection are invalid, and/or the Coupa account used does not have the correct permissions.

Solution

  1. Go to Okta Admin Console and navigate to Applications > Applications > Coupa > Provisioning > Integration > click the Edit button. Enter valid OAuth credentials.
  2. Click Re-authenticate with Coupa.
    • This account must also be an Admin within Coupa.
  3. Back on the Provisioning page in Okta, a message will confirm the successful authentication. Click Save.
  4. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks
Tasks
  1. After identifying the failed task for the user that should be retried, click Retry Selected.
 
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Okta Support - Coupa Provisioning Error "The credentials used to connect to the API were invalid; please check your configuration"