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TravelPerk Provisioning Error: com.saasure.application.generic.client.AppApiException: com.sun.jersey.api.client.UniformInterfaceException: Client Response Status: 400

Okta Integration Network

Overview

TravelPerk's provisioning flow fails with the following error visible in the Okta dashboard:

 

Automatic provisioning of user <username> to app TravelPerk failed: com.saasure.application.generic.client.AppApiException: com.sun.jersey.api.client.UniformInterfaceException: Client response status: 400

 

Error message

Applies To

  • TravelPerk

  • Provisioning

  • Error

Cause

The API authentication token or TravelPerk credentials used for creating the API connection are invalid.

Solution

  1. Go to Okta Admin Console and navigate to Applications > Applications > TravelPerk > Provisioning > Integration > click the Edit button.
  2. Click Re-authenticate with TravelPerk.

  3. Sign in to TravelPerk as an admin user.

  4. When prompted, Authorize app to access the TravelPerk account.

  5. Back on the Provisioning page in Okta, a message will confirm the successful authentication. Click Save.
  6. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.

Tasks

  1. After identifying the failed task for the user that should be retried, click on Retry Selected.

 

Related References

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Okta Support - TravelPerk Provisioning Error: com.saasure.application.generic.client.AppApiException: com.sun.jersey.api.client.UniformInterfaceException: Client Response Status: 400