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Paylocity Provisioning Error "com.saasure.application.generic.client.AppApiException: com.sun.jersey.api.client.UniformInterfaceException: Client Response Status: 400"
Okta Integration Network
Overview

Paylocity's provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <username> to app Paylocity failed: com.saasure.application.generic.client.AppApiException: com.sun.jersey.api.client.UniformInterfaceException: Client response status: 400

 

Error

 

Applies To
  • Paylocity
  • Provisioning
  • Error
Cause
The API authentication token or Paylocity credentials used for creating the API connection are invalid.
Solution
  1. Go to Okta Admin Console and navigate to Applications > Applications > Paylocity > Provisioning > Integration > click the Edit button.
  2. Click Re-authenticate with Paylocity.

  3. A window will open with the Paylocity Login Page. Enter the SCIM user credentials that were set in Paylocity’s SSO Configuration. (These will not be the credentials normally used to login to Paylocity to access the employee information). Documentation: Paylocity: Configuration Guide.

  4. On the Provisioning page in Okta, a message will confirm successful authentication. Click Save.
  5. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.

 Tasks 

  1. After identifying the failed task for the user that should be retried, click on Retry Selected.


Related References

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Paylocity Provisioning Error "com.saasure.application.generic.client.AppApiException: com.sun.jersey.api.client.UniformInterfaceException: Client Response Status: 400"