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DocuSign Provisioning Error "com.saasure.application.generic.client.AppApiException: com.sun.jersey.api.client.UniformInterfaceException: Client Response Status: 400"
Okta Integration Network
Overview

DocuSign provisioning flow fails with the following error visible in the Okta dashboard:

 

Automatic provisioning of user <username> to app DocuSign failed: com.saasure.application.generic.client.AppApiException: com.sun.jersey.api.client.UniformInterfaceException: Client response status: 400

 

Applies To
  • DocuSign
  • Provisioning
  • Error
Cause

The API authentication token or DocuSign credentials used for creating the API connection are invalid.

Solution
  1. Locate and record the DocuSign API account ID:

    1. Sign in to the DocuSign instance with administrator permissions.

    2. Select Settings on the top ribbon. If Settings is unavailable, click the menu icon and select eSignature.

    3. In the left menu below Integrations, click Apps and Keys.

    4. Copy the value in the API Account ID field.

  2. Go to Okta Admin Console and navigate to Applications > DocuSign > Provisioning > Integration > Edit.

  3. In the API Account ID field, enter the API account ID copied in step 1.
    Error messages displayed when authenticating with DocuSign are often caused by an incorrect API Account ID. Make sure the API Account ID and DocuSign administrator credentials match.

  4. Generate the authentication token:

    1. Click Authenticate with DocuSign.

    2. Click Accept if a prompt appears.

    3. If required, enter the email address and click CONTINUE.

    4. If required, enter the password and click LOG IN.

  5. Back on the Provisioning page in Okta, a message confirming the successful authentication will appear. Click Save.

  6. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.Tasks page 

  7. After locating the failed task for the user that should be retried, click on Retry Selected.

 

Related References

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DocuSign Provisioning Error "com.saasure.application.generic.client.AppApiException: com.sun.jersey.api.client.UniformInterfaceException: Client Response Status: 400"