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Box Provisioning Error "com.saasure.application.generic.client.AppApiException: com.sun.jersey.api.client.UniformInterfaceException: Client Response Status: 400"
Okta Integration Network
Overview

Box provisioning flow fails with the following error visible in the Okta dashboard:

 

Automatic provisioning of user <username> to app Box failed: com.saasure.application.generic.client.AppApiException: com.sun.jersey.api.client.UniformInterfaceException: Client response status: 400

Applies To
  • Box
  • Provisioning
  • Error
Cause

The API authentication token or Box credentials used to create the API connection are invalid.

Solution
  1. Go to Okta Admin Console and navigate to Applications > Box > Provisioning > Integration > click the Edit button.

  2. Click Re-authenticate with Box.

    "Re-authenticate with Box" button 

  3. Enter the email and password for the Box admin account and click Authorize.
    "Authorize" button 

  4. Click Grant access to Box.

  5. Back on the Provisioning page in Okta, a message will confirm the successful authentication. Click Save.

  6. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.

 Tasks 

  1. After identifying the failed task for the user that should be retried, click on Retry Selected.

 

Related References

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Box Provisioning Error "com.saasure.application.generic.client.AppApiException: com.sun.jersey.api.client.UniformInterfaceException: Client Response Status: 400"