<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content

Okta SCIM On-Premises Provisioning Fails With Internal Server Error 500

Okta Integration Network
Okta Classic Engine
Okta Identity Engine

Overview

An internal server error occurs during Okta System for Cross-domain Identity Management (SCIM) on-premises provisioning when the SCIM server reports a failure to the On-Premises Provisioning (OPP) agent. Validating the OPP agent token or investigating the SCIM server resolves this issue. When provisioning to an on-premises SCIM server, Okta generates the following error:

 

The Provisioning Agent call to pushProfileUpdate failed. Error code: 500, error: Internal Server Error. Errors reported by the connector : <h1>Server Error (500)</h1>

 

Applies To

  • Okta Identity Engine (OIE)
  • Okta Classic Engine
  • SCIM
  • OPP
  • Profile Push
  • Group Push

Cause

The SCIM server reports this error to the OPP agent, and the SCIM server displays the error for troubleshooting purposes.

Solution

How is the internal server error resolved?

 

Validate the OPP agent token and investigate the SCIM server to resolve the internal server error.

  1. Confirm the token for the OPP agent remains valid.
  2. Verify the SCIM server to see if the token remains valid. The administrator or service provider supporting the SCIM server must perform this investigation.
Loading
Okta SCIM On-Premises Provisioning Fails With Internal Server Error 500 | Okta Support