Okta SCIM On-Premises Provisioning Fails With Internal Server Error 500
Last Updated:
Overview
An internal server error occurs during Okta System for Cross-domain Identity Management (SCIM) on-premises provisioning when the SCIM server reports a failure to the On-Premises Provisioning (OPP) agent. Validating the OPP agent token or investigating the SCIM server resolves this issue. When provisioning to an on-premises SCIM server, Okta generates the following error:
The Provisioning Agent call to pushProfileUpdate failed. Error code: 500, error: Internal Server Error. Errors reported by the connector : <h1>Server Error (500)</h1>
Applies To
- Okta Identity Engine (OIE)
- Okta Classic Engine
- SCIM
- OPP
- Profile Push
- Group Push
Cause
The SCIM server reports this error to the OPP agent, and the SCIM server displays the error for troubleshooting purposes.
Solution
How is the internal server error resolved?
Validate the OPP agent token and investigate the SCIM server to resolve the internal server error.
- Confirm the token for the OPP agent remains valid.
- Verify the SCIM server to see if the token remains valid. The administrator or service provider supporting the SCIM server must perform this investigation.
