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Salesforce's New Profile Do Not Appear In Okta
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

When adding a new profile in Salesforce, the new profile is not reflected in the Okta User Assignments page.

Applies To
  • Salesforce
  • Provisioning
  • Salesforce Profiles
Cause

The changes are not reflected in the Okta User Assignments screen when adding a new profile in Salesforce. This is because the application data from Salesforce is no longer up to date in Okta after changes were made to the Salesforce side.

Please see this article for additional information regarding Application Data.

Solution

Use one of the following methods:
 

Method 1


Re-authenticate API credentials that were used for provisioning to/from Salesforce, which will trigger the download and updating of application data into Okta (this will only refresh the application data for Salesforce):

  1. Go to Okta Admin Console and navigate to Applications > Applications > Salesforce > Provisioning > Integration > click the Edit button.
  2. Verify that the OAuth Consumer Key and OAuth Consumer Secret entered are correct. See Configure OAuth and REST integration for more details
  3. Click Re-authenticate with Salesforce.com.

image.png

  1. In the new window, enter the administrator username and password used to create the Connected OAuth App.
  2. Click Allow to permit access to the Connected App.
  3. On the Provisioning page in Okta, a message confirms successful authentication. Click Save.
  4. Afterward, go to the Assignments tab in the Salesforce App > click the pencil icon to open the Edit User Assignment page > check the Profile URL dropdown to confirm that the new profile is available.

 

Method 2


1. Go to the Okta Admin Console, then navigate to Applications Applications tab and click More to select Refresh Application Data (note that this will trigger an import of application data for all applications configured with Provisioning):
Apps 


2. Go to the Assignments tab in the Salesforce App > click the pencil icon to open the Edit User Assignment page > check the Profile URL dropdown to confirm that the new profile is available.

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Salesforce's New Profile Do Not Appear In Okta