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Microsoft Office 365 New Licenses Do Not Appear in Okta
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

If newly acquired license(s) for Microsoft Office 365 fail to display within Okta while attempting to assign them to new users/groups or edit assignments for currently assigned Office users, it indicates outdated app data within Okta and necessitates a refresh.

Applies To
  • Microsoft Office 365
  • Provisioning
  • Refresh App Data
Cause
The Microsoft Office 365 application data is not updated in Okta.
Solution

Use one of the following methods:

Method 1

Re-authenticate API credentials being used for provisioning to/from Office, which will cause the download and updating of application data into Okta (this will only refresh the application data for Microsoft Office 365).

  1. Go to the Okta admin console and navigate to Applications > Microsoft Office 365 > Provisioning > Integration.

Microsoft Office 365 Integration

  1. Click Re-authenticate with Microsoft Office 365 button, a new window will open, and log in with a Microsoft Global administrator credential with MFA enabled. 

Method 2

  1. Navigate to Okta's admin console.
  2. Then, navigate to the Applications tab and click More to select Refresh Application Data.

NOTE: Refreshing the application data will trigger an import of application data for all applications configured with Provisioning.
Refresh Application Data button   

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Microsoft Office 365 New Licenses Do Not Appear in Okta