<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Retool Provisioning Error "Conflict. Errors reported by remote server: User with that email already exists"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Retool provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <username> to app Retool failed: Conflict. Errors reported by remote server: User with that email already exists

 

Applies To
  • Retool
  • Provisioning
  • Error
Cause

This error occurs because Okta tried to create a specific user but encountered a conflict from the Retool app because the user with the specified email already exists.

Solution
  1. We recommend contacting Retool Support to confirm whether the conflict is legitimate and assist in implementing a resolution.
  2. After resolving the user conflict on the Retool side, attempt the user provisioning again. Go to Okta Admin Console and navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.

Tasks

  1. After identifying the failed task for the user that should be retried, click Retry Selected.
Loading
Retool Provisioning Error "Conflict. Errors reported by remote server: User with that email already exists"