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Microsoft Office 365 Provisioning Error: No prompt for Office 365 Authentication when clicking the "Authenticate with Microsoft Office 365" button
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

When an Okta Admin clicks the "Re-authenticate with Microsoft Office 365" button, a pop-up window is expected to appear, redirecting to the Office 365 Portal, to complete authentication with the Office 365 Global Admin Account and grant Microsoft Graph Admin Consent.

On occasion, customers may notice that after clicking on the Authenticate with Microsoft Office 365 or Re-authenticate with Microsoft Office 365 button ,there is no prompt for the Office 365 Authentication to Grant Admin Consent.

Office 365

When clicking on the Test API Credentials button and attempting to save the configuration, the following error appears:

Error 

Applies To
  • Microsoft Office 365 Provisioning
  • Okta Integration Network 
  • Re-Authenticate with Microsoft Office 365 button not working
  • Unable to complete Office 365 Provisioning > Enable API integration step
Cause

If the Okta Admin does not see any pop-up windows when clicking the "Authenticate with Microsoft Office 365" button, this is typically caused by the web browser's configuration settings having a pop-up blocker feature enabled.

Solution

Determine the status of the web browser pop-up blocker. If enabled, please turn off the pop-up blocker from the web browser configuration, and click on the "Re-authenticate with Microsoft Office 365" button again after a page refresh, and then complete the remaining steps.

For assistance in disabling the pop-up blocker in the web browser, please refer to the Related References section. 

 

If the above does not resolve the issue, unassign the application from Okta and configure it once from scratch on Chrome. Please make sure to do the following steps before configuring it again:

  1. Clear the browser’s cache and cookies, then restart the browser and attempt the authentication again.
  2. Ensure the browsers are updated to their latest versions, as outdated browsers can sometimes cause issues with authentication flows.


 

Related References

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Microsoft Office 365 Provisioning Error: No prompt for Office 365 Authentication when clicking the "Authenticate with Microsoft Office 365" button