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The Authenticate/Re-authenticate Provisioning with Salesforce Window Not Opening
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

The "Authenticate/Re-authenticate with Salesforce" window does not open when trying to enable API for new Salesforce integrations.
Clicking the button does not open the expected window for authentication with the SF administrator credentials (the same ones used to create the Connected SF app) and just throws the error:

Could not verify the Salesforce administrator credentials; please confirm that these are set correctly.


Provisioning 

Applies To
  • Salesforce
  • Okta Integration Network (OIN)
  • Provisioning
Cause

More recent Salesforce instances (and connected apps) have enabled the Require Proof Key for Code Exchange (PKCE) Extension for Supported Authorization Flows option. The Salesforce OAuth configuration with the PKCE feature requires an additional Salesforce code verification step, which cannot be completed during Okta/Salesforce > Authenticate/Re-authenticate with Salesforce steps.

 

Solution

To resolve this, please uncheck the Require Proof Key for Code Exchange (PKCE) Extension for Supported Authorization Flows found in the Salesforce-connected app for Okta. Then, wait for a couple of minutes for the update to be propagated across the system, and then retry the 'Authenticate/Re-authenticate with Salesforce' steps in the Okta Salesforce app so the Enable API integration steps to be completed.

Require Proof Key for Code Exchange (PKCE) Extension for Supported Authorization Flows 

 
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The Authenticate/Re-authenticate Provisioning with Salesforce Window Not Opening