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Pushing Group Results in Error "One or more errors occurred during update group membership"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Push groups fail with the following error:
 

Changes to the Group push mapping for the group [Group Name] could not take effect due to error: Error while updating user group membership for group [Group Name]: One or more errors occurred during update group membership.


Using the Transaction ID for the failed push group, the additional error is seen: 

failure: Not found: Resource not found: [user ID] (User)

 

Applies To
  • Push Groups
  • Enhanced Push Groups
Cause

This error occurs because the push group is still pushing users who were deleted in the downstream application. This breaks the push group as the user cannot be found in the target application. 

Solution

To resolve this issue, the user/users need to be unassigned from the application in the Okta org. 

  1. Using the ID in the secondary log, use the application API to find the username.

  2. If no user is found, compare the times for the push group failures and recent deletions in the target application.

  3. Once the user has been identified, navigate to Applications > Select the application with the push group error.   

  4. Under the assignment tab, unassign the user.

  5. If the user should exist in the target application, reassign the user to the application to initiate the provisioning flow.

  6. Navigate to Push groups and select the Activate flow option.

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Pushing Group Results in Error "One or more errors occurred during update group membership"