<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Slack Push Group Fails to Update Members - Error "400 User Not Found"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Slack push group fails with the following error visible in the Okta dashboard:

 

Unable to update Group Push mapping target App group <group name>: Error while updating user group membership for group <group name>: Bad Request. Errors reported by the connector : {"Errors":{"description":"failed_to_update_members (group=<group name>, reason=user_not_found, failed_users=<externalIds>)","code":400}}

 

Error Message

Applies To
  • Slack
  • Provisioning
  • Group Push
  • Error
Cause

The group push failed because the users (failed_users), as stated in the Okta system log error message, were not found.

Solution

A pushed user must be active in Okta, assigned to the application, part of the Okta pushed group, and provisioned and active on the application side.

  1. Please validate the following for the user listed in the Okta system log error message (failed_users) for the affected Push Group:
  • The user has an active account on the Slack side.
  • The user's External ID on the application assignment in Okta matches the value.
  • The user account was not updated or changed on the Slack side.
  1. Validate and fix the listed users. Then, go to Okta Admin Console and navigate to Applications > Applications > Slack > Push Groups, and attempt the group push again.
Loading
Slack Push Group Fails to Update Members - Error "400 User Not Found"