<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Assigned Application Missing from User's Okta Dashboard
Okta Classic Engine
Okta Integration Network
Overview

An application has been assigned to a user, but the application does not have a tile on that user's dashboard.

Applies To
  • Application Assignment
  • End User Dashboard
  • Okta Classic Engine
Cause
  • Application Visibility is set to Do not display application icon to users under the General tab of the Application.
  • Assigning the application triggered a corresponding task that failed.
  • The user is missing the "external ID" in their application user assignment window.
Solution

Ensure that the Do not display application icon to users checkbox is unchecked under the General tab of the application.
 

Do not display application icon to users checkbox 

 

Below is a general guide to common issues. To ensure the correct solution is applied, search our Knowledge Base with the exact error encountered for a dedicated article.

  1. Navigate to Dashboard > Tasks. 
  2. Look for "Application assignments encountered errors" events such as the following:
    • An invalid Password or A strong password must be chosen.
      • Check the Okta Legacy Password Policy and ensure that it satisfies the service provider's complexity requirements.
      • Ensure the user account configured under API Integration for the application has permission to set passwords in the target application.
    • Unable to assign licenses to the user or similar role/license-related messages.
      • Check to see what license is selected in the user (or group) application assignment.
      • Verify that such licenses are available on the Service Provider side.
    • An error indicating username already exists or is unavailable.
      • Determine whether the user has already created a personal account for the application with the same username that Okta is attempting to use during provisioning.
    • An error indicating a required attribute is missing a value. 
      • Determine what attributes the Service Provider considers required (an error message may specify this).
      • Verify that the required attributes are populated in the user's Okta profile by:
        • comparing the user's profile with another user successfully provisioned and checking the differences between which attributes are populated.
        • navigating to the application profile in the Profile Editor, which will present a list of the application base and custom attributes.  Clicking the info icon of any attribute will indicate whether it is required or not. 
    • An error indicating invalid permissions or credentials.
      • Ensure that the account configured in the application's Provisioning tab has the appropriate level of elevation on the SP side (for example, a Google Workspace Super Administrator account, O365 Global Administrator, etc.).
      • Test the provisioning credentials to rule out an expired or changed password, a deactivated account, etc.

The user with a missing external ID in their application user assignment to the application will not have the application tile showing in their End-User Dashboard. Please check the user assignment to the application (the application that has provisioning enabled) to display the external ID and no red dots that hide provisioning error messages next to their name. 

Loading
Assigned Application Missing from User's Okta Dashboard