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Workflows Jira Service Management Create Request Card Not Working with Error: The field '' could not be found ''
Workflows
Okta Classic Engine
Okta Identity Engine
Overview

Attempting to use the Jira Service Management - Create Request card in Okta Workflows fails with an error similar to the following:

{
  "_error": true,
  "retry_count": 0,
  "flo": 123456,
  "method": "SVaG0KrUJ",
  "execution": "REDACTED",
  "module": "jiraservicedesk.createRequest",
  "kind": "HTTP Request Error",
  "statusCode": 400,
  "headers": {
    REDACTED
    ],
    "date": "Thu, 12 Sep 2024 14:17:28 GMT",
    "content-type": "application/json;charset=UTF-8",
    "server": "AtlassianEdge",
    "nel": "{\"failure_fraction\": 0.001, \"include_subdomains\": true, \"max_age\": 600, \"report_to\": \"endpoint-1\"}",
    "timing-allow-origin": "*",
    "cache-control": "no-store",
    "x-aaccountid": "REDACTED",
    "transfer-encoding": "chunked"
  },
  "body": {
    "errorMessage": "Unable to create request because of these errors : The field '' could not be found.",
    "i18nErrorMessage": {
      "i18nKey": "sd.request.create.error.failed.msg",
      "parameters": [
        "The field '' could not be found."
      ]
    }
  },
  "message": "400 Bad Request",
  "code": 400,
  "description": "HTTP Request Error",
  "steps": 450,
  "source": {
    "flo": "jiraservicedesk:1.0.191:makeCustomCallRetryOn",
    "method": "u0KiSq22Dm4z",
    "execution": "REDACTED",
    "module": "http.call"
  },
  "_fatal": null
}
Applies To
Cause

The error can occur if a Field selected as Input on the Create Request card is removed from the Request Type within the JSM System.

If it is unknown which field was removed, in Workflows, Duplicate the card and compare the Inputs selected on the duplicated card vs the Inputs that are set on the original card.

An example where Affected Hardware was removed on the JSM side:

Affected Hardware

Solution

There are two options to solve this issue:

  1. If the field is needed, re-add it to the Request Type within the JSM system and then use the Create Request card as configured.
  2. If the field is not needed, In Workflows, update the Create Request card to not use the field further.
    1. Click the Settings/Other Options gear icon.
    2. Click Choose fields.

Workflow fields

    1. Select the desired fields and click Save.

Related References

 

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Workflows Jira Service Management Create Request Card Not Working with Error: The field '' could not be found ''