User Rate Limited Errors in Okta System Log
Last Updated:
Overview
Okta generates the following error in the Okta System Log when a user attempts to make more than four calls per second on a user-specific endpoint.
user_rate_limited
The administrator resolves this issue by investigating the authentication source to determine why the user exceeds the rate limit. This error commonly occurs on the /api/v1/authn and /oauth2/v1/token login endpoints.
Applies To
- Okta Identity Engine (OIE)
- Okta Classic Engine
- System Log
- Admin Console
- Rate Limits
Cause
A user attempts to make more than four calls per second on a user-specific endpoint. This commonly occurs on the following login endpoints: /api/v1/authn and /oauth2/v1/token.
Solution
How do administrators resolve the user rate limited error?
To investigate and resolve the rate limit error, investigate the authentication source to determine why the user authenticates and creates more than four calls per second.
NOTE: This rate limit applies to only one user at a time. It does not affect different users because it is a per-user rate limit.
