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Twingate Provisioning "Error while verifying if user <username> exists: Unauthorized. Errors reported by remote server: Invalid token."
Okta Classic Engine
Okta Identity Engine
Okta Integration Network
Overview

Twingate provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <username> to app Twingate failed: Error while verifying if user <username> exists: Unauthorized. Errors reported by remote server: Invalid token

 

Applies To
  • Twingate 
  • Provisioning
  • Error
Cause

This error is generated because the API Token used to create the API connection is invalid.

Solution
  1. Go to Okta Admin Console and navigate to Applications > Applications > Twingate > Provisioning > Integration > Edit.
  2. In the API Token field, copy the SCIM Token from the Twingate Admin Console.
  3. Click Test API Credentials, verify the connection was successful, and then click Save.
  4. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.
  5. After identifying the failed task for the user that should be retried, click on Retry Selected.


Related References

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Twingate Provisioning "Error while verifying if user <username> exists: Unauthorized. Errors reported by remote server: Invalid token."