Atlassian Cloud Provisioning "Error while verifying if user <username> exists: Unauthorized. Errors reported by remote server"
Last Updated:
Overview
Atlassian Cloud provisioning flow fails with the following error visible in the Okta dashboard:
Automatic provisioning of user <username> to app Atlassian Cloud failed: Error while verifying if user <username> exists: Unauthorized. Errors reported by remote server
Applies To
- Atlassian Cloud
- Provisioning
- Error
Cause
The API token or Base URL used for creating the API connection is invalid.
Solution
Please follow the below video or steps:
Go to Okta Admin Console and navigate to Applications > Applications > Atlassian Cloud > Provisioning > Integration > Edit.
-
Enter the SCIM base URL and the API key created in the Atlassian organization.
-
Click Test API Credentials, verify the successful connection, and click Save.
-
Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.
-
After locating the failed task for the user that should be retried, click on Retry Selected.
