TripActions Provisioning "Error while verifying if user exists: Unauthorized. Errors reported by remote server: Authentication failure: invalid token"
Okta Integration Network
Overview

TripActions provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <username> to app TripActions failed: Error while verifying if user <username> exists: Unauthorized. Errors reported by remote server: Authentication failure: invalid token

Applies To
  • TripActions
  • Provisioning
  • Error
Cause
The API authentication token or TripActions credentials used for creating the API connection are invalid.
Solution
  1. Go to Okta Admin Console and navigate to Applications > Applications > TripActions > Provisioning > Integration > click on the Edit button.
  2. Click Re-authenticate with TripActions.
  3. Next, a redirect to TripActions to authenticate will appear. Once redirected, enter the email address and SCIM token obtained from TripActions, and then click Sign In. Once successfully sign in and enter the token, there will be a return to Okta. 
    NOTE: The "Generated Password” in this step asks for the SCIM token generated in TripActions.
  4. Back on the Provisioning page in Okta, a message will confirm the successful authentication. Click Save.
  5. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks. Tasks
  6. After identifying the failed task for the user that should be retried, click on Retry Selected.

Recommended content

No recommended content found...