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Snowflake Push Group Error "Error while updating user group membership for group <group name>: Bad Request"
Okta Classic Engine
Okta Identity Engine
Okta Integration Network
Overview

Snowflake Application push group fails with the following error visible in the Okta dashboard:

 

Unable to update Group Push mapping target App group <group name>: Error while updating user group membership for group <group name>: Bad Request

 

Applies To
  • Snowflake 
  • Provisioning
  • Group Push
  • Error
Cause

Group push will fail with this error if any users in the group that are being pushed to the Snowflake app have not been provisioned and do not exist on the Snowflake side.

Solution
  1. The group cannot be pushed unless all its users are already on the Snowflake side.
  2. A pushed user must be active in Okta, assigned to the application, part of the Okta pushed group, and provisioned and active on the application side.
  3. Please validate the following for the users of the affected Push Group:
    • The user has an active account on the Snowflake side.
    • The user's Username on the application assignment in Okta matches the value in the Snowflake app.
    • The user has an External ID on the application assignment page in Okta.
    • The user account was not updated or changed on the Snowflake side.
  1. Validate all the users of the affected Push Group and ensure they are provisioned successfully to Snowflake. Then, go to the Okta Admin Console, navigate to Applications > Applications > Snowflake > Push Groups, and attempt the group push again.
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Snowflake Push Group Error "Error while updating user group membership for group <group name>: Bad Request"