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Ironclad Push Group "Error while updating user group membership for <group name>: Bad request. Errors reported by remote server: invalid user id: <externalId>"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Ironclad push group fails with the following error visible in the Okta dashboard:

Unable to update Group Push mapping target App group <group name>: Error while updating user group membership for group <group name>: Bad request. Errors reported by remote server: invalid user id: <externalId>
 

Group Push Error

Applies To
  • Ironclad
  • Provisioning
  • Group Push
  • Error
Cause

The group push failed because the user, as stated in the Okta system log error message, was not found.

Solution
  1. Please validate the user listed in the Okta system log error message for the affected Push Group:
    • The user has an active account on the Ironclad side.
    • The user's External ID on the application assignment in Okta matches the value.
    • The user account was not updated or changed on the Ironclad side.
  1. After validating and fixing the listed user, go to Okta Admin Console and navigate to Applications > Applications > Ironclad > Push Groups, and attempt the group push again.

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Ironclad Push Group "Error while updating user group membership for <group name>: Bad request. Errors reported by remote server: invalid user id: <externalId>"