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Salesforce Provisioning Looping while Trying to "Save"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

The provisioning method for Salesforce after migrating to the REST API is stuck after trying to save it.

Applies To
  • Salesforce
  • Provisioning
Cause

After the Provisioning method is changed from the Classic method (username and password + token) to the Rest API method, it may result in not being able to Save it:

  • Navigate to the affected Salesforce app > Provisioning > Integration.
  • Re-authenticate with Salesforce > window pops up.
  • Successfully login > click Allow > window closes.
  • The green message shows up in the UI that it was authenticated
  • Click Save > window load looping with the message: Please wait while we verify your application setup....
  • INVALID_LOGIN shows up after a few seconds in the System Logs.

Salesforce

This can be caused by the app instance used being old. As a result, it utilizes an outdated profile template, which prevents the application from being migrated to use the REST API (OAuth flow).

Solution
Since the current profile template is very old, migrating the profile template to a newer version could be destructive and result in the loss of a lot of user data.

We recommend opening a ticket with Okta Support to check the app instance used. If this is an old one, we recommend creating a new Salesforce application and migrating all of their users to that app.
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Salesforce Provisioning Looping while Trying to "Save"