<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
ServiceNow Provisioning Error: "Error while trying to push profile update for <username>: 403. Operation Failed. Error during update of sys_user (username)"
Okta Classic Engine
Okta Identity Engine
Okta Integration Network
Overview

ServiceNow UD provisioning flow fails with the following error visible in the Okta dashboard:

 

Automatic profile push of user <username> to app ServiceNow UD failed: Error while trying to push profile update for <username>: 403. Operation Failed. Error during update of sys_user (<username>) 

 

Applies To
  • ServiceNow UD
  • Provisioning
  • Error
Cause

The ServiceNow UD account used for creating the API connection does not have the correct permissions on the ServiceNow side. The ServiceNow account needs administrator permissions for the organization.

Solution
  1. Go to Okta Admin Console and navigate to Applications > Applications > ServiceNow UD > Provisioning > Integration > click the Edit button. 
  2. Enter the ServiceNow API Credentials:
  • Admin User Name: Enter a ServiceNow username with administrator permissions for the organization.
  • Admin Password: Enter a password for the administrator account (above).     
  1. Click Test API Credentials, verify if the connection was successful, and click Save.
  2. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.
  3. After identifying the failed task for the user that should be retried, click on Retry Selected.
     

Related References

Loading
ServiceNow Provisioning Error: "Error while trying to push profile update for <username>: 403. Operation Failed. Error during update of sys_user (username)"