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Netskope User Enrollment App Provisioning - "Error while trying to push profile update for <username>: No user returned for user <externalID>"
Okta Classic Engine
Okta Identity Engine
Okta Integration Network
Overview

Netskope User Enrollment provisioning flow fails with the following error visible in the Okta dashboard:

Automatic profile push of user <username> to app Netskope User Enrollment failed: Error while trying to push profile update for <username>: No user returned for user <externalID>

 

Applies To
  • Netskope User Enrollment
  • Provisioning
  • Error
Cause

The Netskope SCIM server returned this error to Okta. When Okta sent the user profile push to Netskope, it failed because the Netskope application did not return any results for the user.

Solution
  1. Netskope reports this error to Okta. As stated in the Okta system log error message, the user with the externalID mentioned does not exist in the Netskope.
  2. If the user has an individual app assignment, unassign and re-assign the user to the Netskope application. Verify whether the user has been successfully assigned to the app.
  3. If the above steps do not work, validate the user's externalID to see if it changed by navigating to the Assignment tab > Search user > click the pencil icon. Then, contact Netskope support for more details on what is causing this error.

 

Related References

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Netskope User Enrollment App Provisioning - "Error while trying to push profile update for <username>: No user returned for user <externalID>"