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Okta Verify "Something went wrong. Please try again" when Signing In on a macOS

Devices and Mobility
Multi-Factor Authentication
Okta Identity Engine

Overview

When attempting to sign in on a macOS using Okta Verify, the following error is encountered:

Something went wrong. Please try again.


Error Message  

 

 

Applies To

  • Okta Identity Engine (OIE)
  • Multi-factor Authentication (MFA)
  • Devices
  • Okta Verify for macOS

Cause

  • For security reasons, Okta does not allow for the inspection or modification of traffic between Okta Verify and its endpoints.
  • A VPN is enabled.

Solution

  1. First, collect Okta Verify Logs from Desktop (macOS / Windows).
  2. Check the specific timestamp of the error, and if there are any of these errors in the logs:

    Sample Okta Verify logs: 

    {🛑 "Loopback": {"message": "Error during authentication flow: accountNotFound", "defaultProperties": "", "location": "LoopbackRequestHandler.swift:handle(_:completion:):64"}}

    {🛑 "Loopback": {"message": "Connection3: HandleLoopback complete failed with: Bad request", "defaultProperties": "", "location": "ServerConnection.swift:processChallengeRequest(request:success:failure:):242"}}

    {🛑 "Storage error": {"message": "Error: itemNotFound", "defaultProperties": "", "location": "OktaKeyValueStorageManager+Enrollments.swift:enrollmentKeys():264"}}

    To ensure proper functionality, it is a must to bypass Okta URLs from any SSL inspection tools. Because the agents utilize SSL pinning, SSL inspection will disrupt all related flows.

 

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Okta Support - Okta Verify "Something went wrong. Please try again" when Signing In on a macOS