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Browser Prompts for Okta Verify Installation even though It Is Already Installed (iOS Devices)
Okta Identity Engine
Multi-Factor Authentication
Overview

This article explains why users are redirected to the Okta Verify installation page on iOS devices when attempting to authenticate with Okta FastPass. This issue occurs after the user initially cancels the prompt to open the Okta Verify application, even if the application is already installed.

Applies To
  • iOS
  • Okta Verify
  • Okta FastPass
  • Okta Identity Engine (OIE)
Cause

On iOS, certain applications or browsing environments require user confirmation to open another application (for example, Safari Private Browsing).

When a user tries to authenticate with Okta FastPass in such environments, the user can see a prompt "Open in Okta Verify". If the user selects Cancel, iOS registers this preference.

Consequently, subsequent attempts to use Okta FastPass from any browser or application fail to launch Okta Verify and instead redirect to the Okta Verify installation page.

"Opne in Okta Verify" prompt  Download Okta Verify 

Solution

To reset this preference and allow Okta Verify to launch correctly, perform the following steps:

  1. Open the Safari browser on the iOS device.
  2. Go to https://login.okta.com/auth/okta-verify.
  3. When the browser displays a prompt to open the page in Okta Verify, select Open.
    Open Okta Verify 
  4. The Okta Verify application will open and display the following message, which is expected:

    Verification Failed

Something went wrong. Please try again.


Error Message 

  1. Return to the original application or Okta tenant and attempt to sign in again using Okta FastPass. The prompt to open Okta Verify will now function correctly.

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Browser Prompts for Okta Verify Installation even though It Is Already Installed (iOS Devices)