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"Matching user not found" Provisioning Error to Downstream Applications
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

This article provides more context surrounding a very common error that can occur when provisioning user accounts downstream to an application:

 

"Matching User Not Found"

 

Applies To
  • Okta Integration Network (OIN)
  • Provisioning
Cause

This error is a result of Okta's attempt to search for an already existing user account on the application side. Okta always attempts to see if the username of the user is already taken before a provisioning request.

When the Create Users provisioning option is turned off, Okta will only attempt to verify if a user with the specified username exists on the application side; if none exists, this error message is thrown.

This error can also occur for an account that has been previously provisioned downstream into the application, and the account was deactivated/deleted directly on the application side, as opposed to the user being deactivated through Okta. 

Solution

To fix this provisioning issue, the user needs to be essentially re-assigned to the Okta application, while making sure the Username provided by navigating to:

  1. In the Okta Admin Console, navigate to Applications > Applications.
  2. Next, select the application.
  3. In the Assignments tab, search for the user, then unassign and reassign the user in the application.

Assignments

 

If the user is assigned through a group, and removing the user from the group will result in the removal of other applications, please do the following:

  1. On the Assignments tab, search for the user, then click the pencil icon next to it.
  2. At the top, under Assignment master, select Administrator.
    • This will ensure that the user is assigned individually and can be removed from the app without being removed from the group assignment.
  3. After that, proceed to assign the user back as an individual. The Convert assignments function can be used to ensure that users are assigned based on existing group assignments.Edit user assignment 

Convert assignment  

This will create a new user account for the user to be synced with Okta if the Create Users provisioning option is enabled. Otherwise, Okta will simply attempt to search for the user in the application using the provided username (under Applications > Assignments, next to the user, click the pencil icon > Username field).

 

Related References

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"Matching user not found" Provisioning Error to Downstream Applications