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How to Send a Branded Activation Email via API on an Org With a Custom Domain
Okta Classic Engine
Okta Identity Engine
Administration
Overview

This article describes how to send a branded activation email via API call on a tenant with a custom domain configured. Each Brand specific email will only work after the Custom Domains are active. After they are active, the URL of the API calls must match the custom domain to which the email is to be sent. 

Applies To
  • API Calls
  • Postman
  • Branded Emails
  • Custom Email Templates
  • Okta Identity Engine(OIE)
  • Okta Classic Engine
Cause
When Admins send Activation emails from the UI the users will receive emails from noreply@okta.com.
Activating the users (and any other similar actions that trigger user-facing emails) from the Admin Dashboard will be associated automatically with the default domain and currently, this cannot be changed
 
Solution

When creating a user via API call, to be able to send them a branded email, the Custom Domain URL should be used when making the call.
Example:

https://<YourCustomDomainURL>/api/v1/users/userId/lifecycle/activate?sendEmail=true


For the user to get an email associated with a Brand it needs to either be triggered by the user while on the Custom Domain associated with the Brand or via API

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How to Send a Branded Activation Email via API on an Org With a Custom Domain