<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Send Custom Branded Emails in Workflows
Okta Classic Engine
Okta Identity Engine
Workflows
Overview

This article provides steps to send custom-branded emails from Okta Workflows after a custom domain is configured in the Okta organization.

Applies To
  • Okta Workflows
Cause

The domain associated with an email depends on how it is triggered. For a user to receive an email associated with a Brand, the email must be triggered either by the user while on the Custom Domain associated with the Brand or via API.

Solution
  1. Configure a CUSTOM domain. See Configure a custom domain and email address for instructions.

  2. Create a new Okta connection with the CUSTOM domain listed in the Domain section. See Create a new connector for instructions. Name this connection something that clearly states the CUSTOM domain is used.
    New Connection    

  3. Create the Workflow that will send the email. Be sure to select the CUSTOM domain connection when adding the card.

NOTE: This example uses the Activate user card.
Custom domain Activation email   

  1. Please confirm the CUSTOM domain is selected as the connection for the Activate user card. 

    NOTE: Only the card that sends the email requires the custom domain connection. All other cards can use either the DEFAULT or CUSTOM domain connection.

    Custom domain activation email  
      

  2. After selecting the CUSTOM domain connection, confirm that the correct name appears in the flow.
    Custom domain activation email  
     
  3. The flow is now configured to send emails using the CUSTOM domain configured within the tenant.

 

Related References

 

Loading
Send Custom Branded Emails in Workflows