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Group Push by Rule Error "Group with same name already exists in AppInstance"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

When performing a Group Push by Rule, the following error occurs:

A Group Push mapping did not get created from rule <rule> to UserGroup <group> since group with same name already exists in AppInstance <app>

 

Applies To
  • Okta Integration Network (OIN)
  • System for Cross-domain Identity Management (SCIM) Provisioning
  • Group Push
  • Group Push by Rule
  • Link Group
Cause

According to the Manage Group Linking Okta documentation, when a group already exists in an application, pushing by rule fails because creating a duplicate group or linking groups is not supported by the rule.

Group push 

Solution

When using the Link Group feature with Okta, Group Push is supported only by name, not by rule. To link an existing group by name, choose Link Group under the Match results and push action. See Configure Group Linking.

NOTE: Group Push by Rule and Okta Group Rules are distinct configurations. Ensure the app is not Using the Same Group for Application Assignment and Group Push.

 

Related References

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Group Push by Rule Error "Group with same name already exists in AppInstance"