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Error "503 Service Unavailable" Encountered With Authentication with BambooHR
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

This article explains why the following error occurs during authentication with BambooHR in an API (Application Programming Interface) integration.

 

503 Service Unavailable


Error message  

Applies To
  • BambooHR
  • Okta Integration Network (OIN)
Cause

The error may occur if the administrator managing the application is inactive or does not have sufficient permissions.

Solution

To resolve this issue, change the subdomain to a dummy value and then revert it to the correct subdomain:

  1. Go to Applications > Applications, then select the BambooHR app.

  2. Select the General tab.

  3. Click Edit and update the Subdomain to any dummy value.

  4. Click Save.

  5. Go to Provisioning > Integration.

  6. Click Edit > Authenticate with BambooHR and complete the authentication flow.

  7. Repeat steps 2 through 4 to update Subdomain with the correct BambooHR subdomain.

  8. Repeat steps 5 and 6 and repeat the authentication flow.

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Error "503 Service Unavailable" Encountered With Authentication with BambooHR