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Microsoft Office 365 API Integration error: "503 Service Unavailable"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

When enabling Microsoft Office 365 API integration by clicking on Authenticate with Microsoft Office 365, the following error appears:

 

503 Service Unavailable.

 

503 error message

Applies To
  • Microsoft Office 365
  • Provisioning
Cause

This error is generated because "Microsoft Tenant Name" is missing in Applications > Microsoft Office 365 > General tab.

App Settings  

Solution
  1. Open an incognito browser window and log in to the Okta tenant.
  2. Go to Okta Admin Console, navigate to Applications > Microsoft Office 365 > General > click Edit > enter the correct Microsoft tenant name, and save the change.
  3. Then navigate to Office 365 > Provisioning > Integration > check Enable API Integration.
  4. Click Authenticate with Microsoft Office 365. The admin is redirected to the Microsoft Azure login page.
    • Log in to the Microsoft Azure account.
    • Read and accept the requested permissions.
    • Upon accepting the scopes in the Microsoft Azure portal, the admin will be redirected back to Okta.
  5. Enter the Office 365 Global Administrator credentials.
  6. Click Test API Credentials.
  7. A message confirming successful authentication will appear, and then click Save.
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Microsoft Office 365 API Integration error: "503 Service Unavailable"