1Password Business Provisioning Error "503 Service Temporarily Unavailable. Errors reported by remote server: Invalid JSON: Unexpected character"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

1Password Business provisioning flow fails with the following error visible in the Okta dashboard:

 

Automatic provisioning of user ****** to app 1Password Business failed: Error while trying to push profile update for *****: 
Service Temporarily Unavailable. Errors reported by remote server: Invalid JSON: Unexpected character ('<' (code 60)): expected a valid value (JSON String, Number, Array, Object or token 'null', 'true' or 'false') at [Source: (String)" <html><head><title>503 Service Temporarily Unavailable</title></head>

 

Applies To
  • 1Password Business
  • Provisioning
  • Error
Cause

This error is generated because there is a problem with the 1Password SCIM bridge and the handshake is failing. Okta is unable to communicate with the 1Password SCIM bridge.

Solution
  1. Refer to 1Password Business: Configuration Guide and If you’re having trouble with 1Password SCIM Bridge. To get more help with the 1Password SCIM bridge configuration, please contact 1Password Business Support.
  2. Once the 1Password SCIM bridge configuration is verified, go to Okta Admin Console and navigate to Applications > Applications > 1Password Business > Provisioning > Integration > Edit.
  3. In the Base URL, enter the URL of the SCIM bridge (not the 1Password account sign-in address). For example: https://scim.example.com.
  4. In the API Token, enter the bearer token for the SCIM bridge.
  5. Click Test API Credentials, verify the connection was successful, and then click Save.

Test API Credentials

  1. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.

 Tasks

  1. After identifying the failed task for the user that should be retried, click on Retry Selected.

 

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