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Emails Not Received Using Configuring a Custom Email Provider
Integrations
Administration
Okta Classic Engine
Okta Identity Engine
Overview

This article addresses a common misconfiguration when setting up a custom email provider.

Applies To
  • Custom Email Provider
  • Gmail
Cause

If the custom sender subdomain includes an underscore, Google will reject the email as the sender domain does not meet the Internet Engineering Task Force (IETF) standard for Domain Name System (DNS).

RFC-5321 states: "To promote interoperability and consistent with long-standing guidance about conservative use of the DNS in naming and applications (for example, see Section 2.3.1 of the base DNS document, RFC 1035 [2]), characters outside the set of alphabetic characters, digits, and hyphen MUST NOT appear in domain name labels for SMTP clients or servers. In particular, the underscore character is not permitted. SMTP servers that receive a command in which invalid character codes have been employed and for which there are no other reasons for rejection MUST reject that command with a 501 response (this rule, like others, could be overridden by appropriate SMTP extensions)".

Solution

To resolve this issue, update the custom email sender configuration to exclude characters other than alphabetic characters, digits, and hyphens. 

  1. Navigate to Settings > Email & SMS.
  2. Select Sender address.
  3. Select Custom email domain.
  4. Enter the Email Address to send from & the name of the sender.
  5. For the Mail domain to send from, ensure it only contains the allowed characters (alphabetic characters, digits, and hyphens).

For example:

  • The original Mail domain to send from was entered as okta_mail.acme.com.
  • Update this to oktamail.acme.com.
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Emails Not Received Using Configuring a Custom Email Provider