Custom Admin Not Receiving Suspicious Activity Email Notifications
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Overview
Custom Admins can be configured to receive suspicious activity email notifications. The goal of this knowledge article is to provide reasons why a Custom Admin is not receiving suspicious activity email notifications, along with the solutions to correct the issue.
Applies To
- Email notifications
- Suspicious Activity Report
- Custom Admins
Cause
There are two possible causes for this issue:
- The Custom Admin role requires Manage Users or Manage Groups permissions to receive suspicious activity email notifications, as user permission is necessary to receive the suspicious email notifications generated by affected users.
- The Custom Admin is experiencing E-Mail Deliverability issues. This issue is visible in the system log by using the following query:
eventType eq "system.email.delivery" and outcome.result eq "FAILURE"
Solution
Administrators should first verify that the Custom Admin role is granted the Manage Users permission.
- Grant the Manage Users permission to the Custom Admin role.
- For this role, edit the assigned resource set and verify that All users is selected.
- Click Save.
NOTE: A service account can be configured to receive the emails and automatically forward them as needed.
If the above permissions are assigned correctly, and the Custom Admin role already has the Manage Users permission, then the issue can be further investigated by following the Troubleshooting E-Mail Deliverability steps.
