<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Cannot Create a CNAME Record Because Another Record with the Same Name Already Exists
Okta Classic Engine
Okta Identity Engine
Administration
Overview

When configuring custom redirect domains or custom email domains, admins need to create CNAME records with the DNS provider according to the values provided in the Okta Admin Console. This will not be possible if CNAME/A/AAAA records already exist for the same alias.

Applies To
  • Custom URL
  • Custom Email Domain
  • DNS Records
Cause

CNAME records map an alias to a "true name" (canonical name), while A and AAAA records associate an alias to an IP address (v4 or v6, respectively). Having multiple such records for a single alias would provide conflicting information to the DNS servers, and as such DNS providers do not allow the creation of a second CNAME/A/AAAA record once one already exists for the given name. More details about how the DNS records work can be found in the RFC 1034 technical document.

Solution

To configure a custom redirect URL or email sender in Okta for the same domain, admins will need to use subdomains to differentiate from existing DNS records. For instance, instead of using "noreply@customdomain.com", one can use "noreply@okta.customdomain.com". This will result in a different alias that does not conflict with preexisting records.

Loading
Cannot Create a CNAME Record Because Another Record with the Same Name Already Exists