<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Microsoft Office 365 Push Group Error "Could not create Office 365 group because the name is already in use, received error: The group already exists"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Microsoft Office 365 push group fails with the following error:
 

Unable to update Group Push mapping target App group <group>: Could not create Office 365 group <group> because the name is already in use, received error: The group <group> already exists.

 

Applies To
  • Microsoft Office 365
  • Provisioning
  • Push Group
Cause

The push group failed because creating a duplicate group is not supported. As stated in the Okta system log error message, the group already exists in the Microsoft Office 365 application.

Capabilities

 
Solution

This is expected behavior. When a group already exists in Microsoft Office 365, pushing the group from Okta fails because creating a duplicate group is not supported.

To determine if the application integration supports group linking, check the Capabilities/Provisioning section for the application in the Okta Integration Network catalog.

The Microsoft Office 365 application does not support group linking. 
Provisioning Capabilities 

Related References

Loading
Microsoft Office 365 Push Group Error "Could not create Office 365 group because the name is already in use, received error: The group already exists"