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Attempting to Re-enroll a Previously Enrolled Server into ASA Project Fails with Error "Server is deleted"
Advanced Server Access
Okta Classic Engine
Okta Identity Engine
Overview

When trying to enroll a server into ASA, where that server had previously already been enrolled into the ASA Project but has since been deleted, enrollment is now failing. The server agent logs may show errors such as:

time="2023-06-14T15:53:15-04:00" level=info msg="Attempting automatic server token refresh" task=refreshServerToken token_path="C:\\Windows\\system32\\config\\systemprofile\\AppData\\Local\\ScaleFT\\state\\device.token" time="2023-06-14T15:53:15-04:00" level=error msg="automatic refresh server token failed" err="Server is deleted" task=refreshServerToken time="2023-06-14T15:53:15-04:00" level=error msg="task init failed" err="Server is deleted" task=refreshServerToken time="2023-06-14T15:53:15-04:00" level=error msg="task init failed" err="Server is deleted" task=refreshServerToken time="2023-06-14T15:53:15-04:00" level=error msg="Error in mainLoop(), retrying" error="Server is deleted" retry_in=9m45.422758793s

Applies To
  • Advanced Server Access (ASA)
Cause

The server agent builds a "state" directory that contains internal databases and caches. If the server had previously been enrolled in ASA, this directory may contain cached information about the initial enrollment that will cause a conflict when the server tries to re-enroll into the project.

Solution
  1. Stop ScaleFT Server Tools service (sftd on Linux) on the affected server.
  2. Manually delete the ScaleFT directory from the server that contains the cached "state" information:
    • On Windows servers: C:\Windows\System32\config\systemprofile\AppData\Local\ScaleFT/.
    • On Linux servers: /var/lib/sftd.
  3. Restart the ScaleFT Server Tools service and wait a few minutes. Monitor to see if the server gets enrolled.

 

If the issue persists, it is recommended to also try to uninstall/re-install the ScaleFT Server Tools:

  1. Stop/uninstall the ScaleFT Server Tools on the affected server.
  2. Manually delete the ScaleFT directory from the server that contains the cached "state" information:
    • On Windows servers: C:\Windows\System32\config\systemprofile\AppData\Local\ScaleFT.
    • On Linux servers: /var/lib/sftd.
  3. Re-install the ScaleFT Server Tools and re-attempt to enroll the server:
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Attempting to Re-enroll a Previously Enrolled Server into ASA Project Fails with Error "Server is deleted"