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Issues with SSH to SuSE Server via ASA/OPA after Reinstallation of Server Agent
Advanced Server Access
Okta Classic Engine
Okta Identity Engine
Overview

The Server Agent is having issues after being reinstalled on a SuSE server. Users may be unable to SSH to the server via Advanced Server Access (ASA)/ Okta Privileged Access (OPA), and see continuous errors such as the following in sftd logs:

"MESSAGE" : "time=\"2023-08-16T14:41:36-05:00\" level=error msg=\"Error in brokerparent.Run!\" error=\"user: unknown user sftd\""
"MESSAGE" : "time=\"2023-08-16T14:41:51-05:00\" level=error msg=\"Error setting up child options\" error=\"user: unknown user sftd\""  


It may be observed that while the "sftd" group does exist in /etc/group, the "sftd" user does not exist in /etc/passwd.

Operating System (OS) logs may show "useradd" attempts for "sftd" failing:

2023-08-16T22:24:27.345229+00:00 testserver useradd[41029]: failed adding user 'sftd', exit code: 9

 

Applies To
  • Advanced Server Access (ASA)
  • Okta Privileged Access (OPA)
  • SuSE 12 or SuSE 15
Cause

The uninstall script for scaleft-server-tools performs a "userdel" to delete the user "sftd". In most OSs, this will also delete the "sftd" group, but in SuSE, the "userdel" operation will only delete the user.

With the "sftd" group still existing, the next "useradd" for sftd upon subsequent re-installation will fail.

Solution
  1. Stop sftd service and uninstall the ScaleFT Server Tools:
    sudo zypper rm -u scaleft-server-tools
  2. Manually remove the "sftd" group:
    groupdel sftd
  3. Reinstall the ScaleFT Server Tools: Install the Advanced Server Access server agent on SuSE Linux  
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Issues with SSH to SuSE Server via ASA/OPA after Reinstallation of Server Agent