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Atlassian Confluence Server Provisioning Error "Failed to verify a user exists from Confluence: Failed to login to Confluence"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Atlassian Confluence Server provisioning flow fails with the below error visible in the Okta dashboard:

Automatic provisioning of user <username> to app Atlassian Confluence Server failed: Failed to verify a user exists from Confluence: Failed to login to Confluence
 

Error Message

This error appears despite the following being true:

  • The Confluence URL entered in Applications > Atlassian Confluence Server > General tab is correct.
  • The provided Confluence API Credentials Admin User Name and Admin Password are correct.

This article explains why this error is seen and how to resolve it.

Applies To
  • Atlassian Confluence Server
  • Provisioning
  • Error
Cause
The communication between the on-premise Confluence server and Okta is blocked.
Solution
  1. Ensure that communication between the on-premise Confluence server and Okta is not blocked.
  2. Afterward, go to Okta Admin Console and navigate to Applications > Applications > Atlassian Confluence Server > Provisioning > Integration > click the Edit button.
  3. Enter the correct Confluence API Credentials Admin Username and Admin Password, then click Test API Credentials. Once it is successful, save it.
  4. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under TasksFailed Tasks in Okta Dashboard 
  5. After identifying the failed task for the user that should be retried, click on Retry Selected.

 

Related References

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Atlassian Confluence Server Provisioning Error "Failed to verify a user exists from Confluence: Failed to login to Confluence"