Unable to Install the Okta AD Agent With AWS Simple AD
Last Updated:
Overview
When connecting the Okta Active Directory (AD) Agent to Amazon Web Services (AWS) Simple AD, Okta generates error messages. This issue occurs because AWS Simple AD does not meet the underlying requirements for integration and is unsupported. Administrators must use an alternative directory service instead of AWS Simple AD.
One or both of these errors may appear in the AD Agent log:
Service Okta AD Agent was not found on computer. The specified service does not exist as an installed service.
Unexpected error: The security database on the server does not have a computer account for this workstation trust relationship.
Applies To
- Okta Identity Engine (OIE)
- Okta Classic Engine
- Active Directory (AD)
- Agent to Amazon Web Services (AWS)
- Directories
- Okta AD Agent
Cause
AWS Simple AD does not meet the underlying requirements for integration with the Okta AD Agent.
Solution
Does the Okta AD Agent support integration with AWS Simple AD?
The Okta AD Agent does not support this specific integration. Implement an alternative directory service instead of AWS Simple AD.
