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Error "Unable to connect to the server. Please check your network connection" when Calling api/v1/sessions/me
Okta Classic Engine
Okta Identity Engine
Administration
Overview

While calling the api/v1/sessions/me endpoint, the following error is being returned:

Unable to connect to the server. Please check your network connection.

 

Applies To
  • OpenID
  • Cross-Origin Resource Sharing (CORS)
  • Developer
  • Okta Classic Engine
Cause
The domain from which the call originates is not added as a Trusted Origin for CORS in Okta.
Solution

Add the URL that is calling /api/v1/sessions/me as a Trusted Origin for CORS in Okta. To do that:

  1. Go to the Okta Admin UI Security API Trusted Origins Add Origin.

Add Origin

  1. Add https://www.example.com and enable Cross-Origin Resource Sharing (CORS)

 enable CORS  

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Error "Unable to connect to the server. Please check your network connection" when Calling api/v1/sessions/me