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Okta is Not Deprovisioning Users
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Okta is not deprovisioning users from applications even though the Deactivate Users provisioning option is enabled.
 

Applies To
  • Provisioning
  • Deactivate Users
  • External ID
  • Okta Classic Engine
  • Okta Identity Engine (OIE)
Cause
Users were assigned to the application in Okta before Provisioning was enabled and do not have an External ID on their application profiles in Okta.
Solution
  1. On the Okta Admin Console, navigate to Applications > Open the desired Application.
  2. Switch to the Assignments tab.
  3. Click the X next to the assignment to unassign users/groups from the application in Okta.
  4. Click the Assign button to reassign the users/groups to the application in Okta.

Validate the presence of External IDs by clicking the pencil icon next to the user's assignment in the Okta application.

Edit User Assignment 

NOTE: Uncheck the Deactivate Users provisioning option before performing this action to avoid user deactivations (applies to users added after provisioning was enabled for the application in Okta).

 

Deactivate users

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Okta is Not Deprovisioning Users