<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Okta Accounts Created and Activated by SailPoint Are Not Receiving Activation Emails
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

SailPoint was integrated and used to create Okta accounts. When activating an account in SailPoint, it is successfully provisioned in Okta, and the account is created as activated. However, activation emails from Okta are not being sent to users. No email protection services are blocking these emails within the organization.

Applies To
  • SailPoint Integration
  • Okta End user emails
Cause
  • The user only receives the activation email if there is no password set when the user is created.
  • If SailPoint creates the users with a password, even a temporary one, no activation emails are sent to users from Okta.
Solution

If the users should receive the activation emails from Okta upon activation, create the users without a password.


NOTE: If it is mandatory to create the user with a password but still want an email to be sent, make a second API request which sends a password reset email as mentioned in Reset password API and make sure to set the sendEamil parameter to true. The reset password email can be customized to look like a welcome email if needed.

Loading
Okta Accounts Created and Activated by SailPoint Are Not Receiving Activation Emails