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Google Workspace Provisioning Error "Automatic provisioning of user to app Google Workspace failed: Failed to push profile update. Resource Not Found"
Okta Integration Network
Overview

Google Workspace provisioning flow fails with the following error visible in the Okta dashboard.

Automatic provisioning of user <username> to app Google Workspace failed: Failed to push profile update. Resource Not Found: <resource>

Error Message

Applies To
  • Google Workspace
  • Provisioning
  • API
Cause

This error is due to one of the following reasons:

  • The Google Workspace administrator credentials used for creating the API connection are invalid.
  • The authentication token is invalid.
  • The permissions of the account used for creating the API connection are incorrect on the Google Workspace side. Permissions of the account may have changed, and it is not the Google Workspace Admin account.
  • The end user's Google account was recently recovered and has not completed the security hold waiting period.
Solution

Solution 1: Re-authenticate the integration with Google Workspace 

  1. Go to Okta Admin Console and navigate to Applications > Applications > Google Workspace > Provisioning > Integration > click the Edit button.

  2. Click Re-authenticate with Google Workspace.

Integration
  1. Enter the Google Workspace Admin account credentials:
  • Enter the admin username.
  • Enter the admin password.
  • Review the list of permissions Google will grant Okta in the Google Workspace tenant. If acceptable, click Allow.
  1. Back on the Provisioning page in Okta, a message will confirm the successful authentication and click Save.
  2. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.
Tasks
  1. After identifying the failed task for the user that should be retried, click on Retry Selected.

 

Solution 2: Wait for the Google Account Recovery Security Hold Period

If the Google account was recently recovered, it will need to wait 24-48 hours for the recovered account to be fully active. Google places a security hold on recovered accounts as a security measure for their recovery process. Once the security hold period has been completed, proceed to retry the failed task or re-assign the user to the application.


Related References

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Google Workspace Provisioning Error "Automatic provisioning of user to app Google Workspace failed: Failed to push profile update. Resource Not Found"