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"Failed to load" Error when Using an Okta Action Card in a Workflow
Workflows
Okta Classic Engine
Okta Identity Engine
Overview

When using an Okta Action card in a workflow, the card may timeout after 60 seconds when attempting to load the input and output fields, resulting in a message similar to one of the following:

 

Failed to load



Failed to load field   Failed to Load  

 

Applies To
  • Okta Workflows
  • Okta connector Action cards
Cause

This error can occur for several different reasons:

  • An Okta connection has not been created, or the connection used by a card no longer exists.
  • The Okta connection is invalid and needs to be reauthorized.
  • The User who last authorized/re-authorized the Okta Connection does not have proper permissions in Okta Core to perform the requested action (that is, Super Admin or Custom Role)
  • The Okta API Scopes required by the action card have not been granted.
Solution

To resolve the issue, check the following:

  1. Verify that an Okta connection exists and has been successfully authorized. If there is an issue with the Okta connection, there will usually be a visual indication that it needs to be reauthorized. Use the Test Connection option from the connection's context menu to confirm that it tests successfully.
  2. The User who last authorized/re-authorized the Okta Connection has the proper permissions in Okta Core to perform the requested action (that is, Super Admin or Custom Role).
  3. Verify the scopes required by the card being used have been granted. Identify which scopes are needed based on the scope names and what the action card does:
    1. In the Okta Admin console, navigate to Applications > Applications.
    2. Click on the Okta Workflows OAuth app.
      Apps  
    3. Navigate to the Okta API Scopes tab and grant the required scopes by clicking the Grant button next to each scope.
  4.  Reauthorize the Okta connector.

 

 Related References

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"Failed to load" Error when Using an Okta Action Card in a Workflow