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Custom Authorization Server Tab Is Missing from the API Menu
API Access Management
Overview

This article describes how to enable the option to create a Custom Authorization Server, as the Authorization Servers tab will be missing under Security > API.

tab missing

 

Applies To
  • Authorization server tab
  • Custom authorization server
  • Custom default authorization server
  • Org authorization server
Cause

The feature called API Access Management must be enabled.

Solution

This is a paid feature, so please contact the designated Okta Account Manager to learn more about pricing directly. If there is no Account Manager assigned or do not know the account owner's contact information, reach out to our Sales Team. Details on Contact us page.

 

After the API AM feature is enabled, the Authorization Servers tab should appear under Security > API

Authorization Servers tab visible  


To perform SSO with Okta for the OpenID Connect apps or to get an access token for the Okta APIs, use the Okta Org Authorization Server. Otherwise, if access tokens are needed to protect the APIs, then a Custom Authorization Server will most likely be needed.

 

NOTE: All Okta Samples or SDKs are designed to use a Developer account with a template custom authorization server called default. However, almost all of these samples/SDKs support using the Org Authorization Server. Refer to the SDK's documentation to see how to set the issuer or for information about whether it requires the use of a Custom Authorization Server.

 


Related References

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Custom Authorization Server Tab Is Missing from the API Menu